Joomla Blog

Tutorials, reviews, case studies and other tips to help website owners and website developers master the Joomla content management system.

Cannot find XML setup file

Posted by on in Error Codes
  • Font size: Larger Smaller
  • Hits: 16557
  • 2 Comments
  • Subscribe to this entry
  • Print


If you are installing an extension such as this, you will most likely see that the file has the words "unzip first" somewhere in the file name, or at least something very similar. There are occasions where the file name will leave this out and the installation instructions will fail to mention this as well. The nice thing about this situation is that it's very easily fixable. Remember to make sure that the extension version matches the Joomla version you are using as well.

This can also happen when you are installing a large extension on a system that can't handle the number of files in the package. If you suspect that this may be the case, you will probably need to manually install the extension through the use of FTP and Joomla's tmp directory.  We've explained how to install a Joomla extension manually here.

Lastly, you might want to try re-downloading the extension files from the developer to ensure that they haven't become corrupted during download or upload.

If you've come across this error before and resolved it in another way, please leave your comments below explaining just how you solved your problem.

If you're experiencing this problem and can't seem to solve it, drop a question into our user forum.

Rate this blog entry:
0
Build A Joomla Website writer and moderator, lover of CSS...waiting for hockey season to start again.

- Is responsive web design all it's cracked up to be?

Comments

  • Guest
    Beto Tuesday, 13 November 2012

    hi, I'm having problems to update my version of Joomla, I'm using the 1.5.23 that came with the Sympatico application in CPanel, and I want to use a template that requires Joomla 2.5, I have spent around 3 days trying to upgrade my version thru different patches but I always receive this error "cannot find xml setup file", I already unzip the file and well is not working, I would appreciate any help, thanks and blessings !

  • Robert Wilson
    Robert Wilson Thursday, 15 November 2012

    Hi Beto,

    If you haven't gotten the Joomla version upgraded yet, nothing you do will make the 2.5 template install into a 1.5 Joomla site. They just aren't compatible.

    Go through our free course, The Basics, very carefully and you will learn how to install the correct version of Joomla. You can then use your 2.5 template.

    Hope that helps.

Leave your comment

Guest Saturday, 25 October 2014